Modules & iCalendar Feed 3.0.3

Stable version of activeCollab 3 has been released on May 21st 2012. The historical information on these pages is provided for information only, and is no longer relevant! Please use other non-archived forums to ask questions and get relevant information.

avatar Erik Pro Mar 16. 2012. 9:07 pm
When is the iCal feed going to be working?

Right now I get "A calendar wasn’t found on webcal://XXXX/public/index.php. Check the URL" when subscribing via iCal.


Also I don't want to use the invoicing module, when I disable it the invoice module it still shows in the nav.
littlerocket.ca
avatar Jason A. Pro Mar 16. 2012. 11:31 pm
Erik, you refreshed a few times and the module stayed in your nav? We also won't be using invoicing but tried it out.
Once we disabled it we refreshed and it was gone form the nav exactly as it should have.
avatar Ilija S. Staff Mar 17. 2012. 12:49 am
Hello Erik,

We worked on iCalendar feeds for upcoming activeCollab 3.0.4 beta. They are still read only and work in pretty much the same way as they did in activeCollab 2.3.8.

When you uninstall a module, disable it or change system permissions, you should refresh the entire page. This bug has been covered for v3.0.4, but 3.0.3 requires refresh.
avatar Erik Pro Mar 17. 2012. 1:39 pm
OK cool. Jason A, seems to be gone :)
littlerocket.ca
avatar Jason A. Pro Mar 31. 2012. 8:31 pm
Ilija, FYI the iCal feed (iCal for OS X Lion) still breaks for me with 3.0.6 with popup error saying that "the data from {url} isn't valid.

Trying the same thing in Google Calendar resulted in essentially the same thing : error popup with "... did not contain a calendar in valid ical or gdata format"
avatar Ilija S. Staff Mar 31. 2012. 8:44 pm
Hello Jason,

Yes, we are aware that iCalendar feeds are not working in activeCollab 3.0.6. It's a known problem what we worked on last week (tested Outlook, iCal and Google Calendar), so fix will ship with activeCollab 3.0.7.
avatar Jason A. Pro Apr 9. 2012. 2:28 pm
Hey Ilija, FYI 3.0.8 iCal/GoogleCal still fails for us
avatar Ilija S. Staff Apr 9. 2012. 3:05 pm
You get authentication error in iCal?
avatar Jason A. Pro Apr 9. 2012. 4:56 pm
Now it is back to the original error :

There was an error subscribing to the calendar.
There was an unexpected error with the request on subscribed calendars (error -1).

Google Cal is something like "There was an error loading the URL"
avatar Ilija S. Staff Apr 9. 2012. 4:58 pm
Hello Jason,

Did you check your system role and made sure that you have Can Use Feeds permission set to yes?
or Go To Next Page

Try activeCollab for 30 days

Instant access and no credit card required

.manageprojects.com