Security with WiFi activeCollab users

This topic is archived because there were no new posts for more than 12 months. The historical information on these pages is provided for information only, and may no longer be relevant!

Please, don't base your purchase decisions on information provided at this page, and consider starting a new topic instead

avatar ShyKatGames Pro Oct 8. 2010. 10:04 pm
My concern is that a number of my users sometimes use public WiFi to connect to my activeCollab site, and I am concerned that their posts both text and images can be viewed by other people on the public WiFi or that the owner of the public WiFi can snoop on historical traffic. Perhaps I am being paranoid, perhaps the traffic into my activeCollab site isn't clear text and is actually encrypted.
If anyone could let me know what steps I need to do beyond what I get from out of the box activeCollab to help secure my users interactions to my activeCollab from WiFi ( beyond telling them not to connect from WiFi )
avatar 7elix Pro Oct 9. 2010. 1:33 pm
Use https for your installation. Traffic between the server and the browser will be securely encoded.
avatar manoj Pro Oct 10. 2010. 7:01 pm
I tried setting up the SSL. However, whenever we click on any link it searches http: and gives error. It should automatically go to https.

Any solutions?
avatar protocreate Pro Oct 10. 2010. 9:06 pm
If your using Apache with mod_rewrite for your server (or something compatible with it) then you could do something like this in your .htaccess file:

RewriteEngine On 
RewriteCond %{SERVER_PORT} 80 
RewriteRule ^(.*)$ https://www.example.com/$1 [R,L]


This will rewrite all normal http requests to https
avatar Dušan Marić Pro Oct 11. 2010. 9:50 am
@ShyKat_Games:

activeCollab doesn't encrypt the data by default and if you're concerned about that your data can be intercepted and want to ensure their safety, you can configure activeCollab to serve content through HTTPS in order to have SSL encryption in place. For more information regarding it please read the following Administrator's Guide article: Securing your System.

@expersissoftware:

If you're already having SSL enabled on your web server then make sure that ROOT_URL constant value in /config/config.php file is appropriately set to use HTTPS instead of HTTP
activeCollab team member

Try activeCollab for 30 days

Instant access and no credit card required

.manageprojects.com