activeCollab 3.0.6 BETA, Available for Download

Stable version of activeCollab 3 has been released on May 21st 2012. The historical information on these pages is provided for information only, and is no longer relevant! Please use other non-archived forums to ask questions and get relevant information.

avatar Ilija S. Staff Mar 27. 2012. 5:33 pm
Hi everyone,

Today we are releasing a new activeCollab 3 beta build - activeCollab 3.0.6. This particular release is all about bug fixes and small enhancements (like it should be now that we are getting close to stable version):

1. Print should be feature complete now. If you see anything missing, just let us know.
2. Final model clean up (there should be no significant database changes by the time activeCollab 3 stable is out).
2. Improvements to tracking reports - support for multi-currency reporting, bug fixes and tweaks.
3. Fixes to mailing to ensure mail delivery and fix potential privacy issues.
4. Bug fixes across the board - from source module, visual editor, mobile interface to some small, under the hood tweaks.

activeCollab 3.0.5 is available as an additional download on your profile page:



Note that this release is still considered beta, and is it should not be used in production.

Thank you for your continued support.

PS: If you are using activeCollab 2.3.8, you can test upgrade process by following these instructions. Note that you should not upgrade your production setup. Instead, create a test copy (if you don't have it already) and run the upgrade there.
avatar Alex S. Pro Mar 27. 2012. 10:36 pm
I'm getting this error when upgrading from 3.0.5:

Update configuration options (Query failed with message 'Duplicate entry 'notifications_from_force' for key 'PRIMARY'' (SQL: INSERT INTO acx_config_options (name, module, value) VALUES ('notifications_from_force', 'system', 'b:1;')))
Cheers - Alex
avatar Ilija S. Staff Mar 28. 2012. 12:39 am
Hello Alex,

Are you sure that you didn't run activeCollab upgrade script twice? I don't see that this query is repeated, and notifications_from_force is new to activeCollab 3.0.6 (never been used in older releases, 100% sure about it because I've added it).
avatar Ilija S. Staff Mar 28. 2012. 9:46 am
Just got informed that activeCollab Manager friendly builds are uploaded. Give it a try.
avatar Alex S. Pro Mar 28. 2012. 12:11 pm
Quite possible, since my browser autologged in and refreshed the page for some reason. Would that trigger the whole script to run?
Cheers - Alex
avatar Ilija S. Staff Mar 28. 2012. 12:18 pm
Hello Alex,

It shouldn't - upgrade script can't be triggered simply by visiting it, you need to provide administrator credentials.
avatar Alex S. Pro Mar 28. 2012. 4:25 pm
To clarify, I visited the upgrade page and LastPass automatically filled in my username and password then clicked Login, but it refreshed the page immediately so I didn't see the upgrade execute in my browser.
Cheers - Alex
avatar Ilija S. Staff Mar 28. 2012. 4:31 pm
Does your activeCollab work now?
avatar Alex S. Pro Mar 28. 2012. 4:36 pm
Yes, hopefully this won't have caused any problems with it!
Cheers - Alex
avatar Ilija S. Staff Mar 28. 2012. 4:45 pm
Hi Alex,

activeCollab 3.0.5 to 3.0.6 upgrade script broke on first command of the first step so it did not do any data transformations, no worries.
or Go To Next Page

Try activeCollab for 30 days

Instant access and no credit card required

.manageprojects.com